please use vxzoc.com



 
HomePortalCalendarGalleryFAQSearchMemberlistUsergroupsRegisterGalleryLog inDonate
Site stickers are NOW BACK IN STOCK !!!!!!!!!!!!!
This forum is now CLOSED! Please visit our new site - www.vxzoc.com

Share | 
 

 zafira 2.0 DTi

View previous topic View next topic Go down 
AuthorMessage
Brown93
Newbie
Newbie


Posts : 11
Join date : 2010-07-04

PostSubject: zafira 2.0 DTi   Sun Jul 04, 2010 9:44 pm

My dads zafira runs like a bag of crap at the minute. It will just randomly jump into limp mode and it is making all of us at our garage bang our heads off the wall. last year it flagged up the EGR valve so we coughed up £200 and replaced that 1 year later it is at it again. We have been told to change the boost pressure solenoid and have been given two spare ones but that hasnt worked.
Does anybody on here know how to over come this problem, help would be greatly appreciated. I can get some pictures of the fault codes which the car brings back on monday.
Thanks Dan
Back to top Go down
View user profile
supersterl
Admin
Admin


Posts : 1353
Join date : 2009-11-25
Age : 60

PostSubject: Re: zafira 2.0 DTi   Sun Jul 04, 2010 10:08 pm

put the codes on Dan and im sure that someone here might be able to help you out..

_________________
Drives a Zafira GSI Turbo..in Arden Blue
Back to top Go down
View user profile
Brown93
Newbie
Newbie


Posts : 11
Join date : 2010-07-04

PostSubject: Re: zafira 2.0 DTi   Mon Jul 05, 2010 12:40 am

all get it on the kts on monday didnt have a chance yesterday because we where busy
Back to top Go down
View user profile
Brown93
Newbie
Newbie


Posts : 11
Join date : 2010-07-04

PostSubject: Re: zafira 2.0 DTi   Mon Jul 05, 2010 8:32 am

Right found/got some screenshots of the codes,
We put the computer on, on the 10th april and it brought back these codes,



We found a broken wire to the EGR valve we then cleared all the faults and the car ran fine until now
My dad put the computer on today and it flagged up:


Any suggestions??
Back to top Go down
View user profile
Brown93
Newbie
Newbie


Posts : 11
Join date : 2010-07-04

PostSubject: Re: zafira 2.0 DTi   Thu Jul 08, 2010 9:08 am

any suggestions we are thinking along the lines of air mass meter but the problem is its a £110 part
Back to top Go down
View user profile
Brown93
Newbie
Newbie


Posts : 11
Join date : 2010-07-04

PostSubject: Re: zafira 2.0 DTi   Mon Jul 19, 2010 8:27 am

Just if anyone else has this problem, the fault was the egr valve was solid with carbon, all you have to do is clean it up, make sure u can move the solenoid then jobs done
Back to top Go down
View user profile
Robbo
Admin
Admin


Posts : 292
Join date : 2010-07-05
Age : 40

PostSubject: Re: zafira 2.0 DTi   Mon Jul 19, 2010 8:45 am

Thanks for keeping us updated, this info will be a great help to others having problems.
Back to top Go down
View user profile
supersterl
Admin
Admin


Posts : 1353
Join date : 2009-11-25
Age : 60

PostSubject: Re: zafira 2.0 DTi   Mon Jul 19, 2010 9:27 am

Glad you got it spoted and let us know what it was ..

_________________
Drives a Zafira GSI Turbo..in Arden Blue
Back to top Go down
View user profile
Brown93
Newbie
Newbie


Posts : 11
Join date : 2010-07-04

PostSubject: Re: zafira 2.0 DTi   Wed Jul 21, 2010 3:16 am

Just glad its sorted lol the IAT sensor would of cost £110 + VAT so glad it was not that. Apparently on them the EGR valve opens it self up to clean itself however, it jammed open causing loss of power
Back to top Go down
View user profile
RICHARDSDTI
Member
Member


Posts : 130
Join date : 2010-08-01
Age : 36

PostSubject: Re: zafira 2.0 DTi   Mon Aug 02, 2010 5:16 am

I had an egr valve fault last week and after speeking to a few people found out that if you buy one from vauxhall you get the whole inlet manifold. cos it gets gummed up inside. it might not solve the fault codes but cleaning the manifold out might prolong life of the egr valve.
Back to top Go down
View user profile
Brown93
Newbie
Newbie


Posts : 11
Join date : 2010-07-04

PostSubject: Re: zafira 2.0 DTi   Mon Aug 02, 2010 9:06 am

well the car went into limp mode when i examined the exhaust manifold it was clogged up so i blasted the manifold out and used some engine flush and now its spot on
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: zafira 2.0 DTi   Today at 5:07 pm

Back to top Go down
 
zafira 2.0 DTi
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Write-Up: Installing SLP Exhaust Headers
» Vw t4 trooper 12v socket
» Radiator Leak FIXED
» No dash lights / won't start
» Need help with intermittent stalling/long crank time to start

Permissions in this forum:You cannot reply to topics in this forum
 :: ZAFIRA A CHAT-
Jump to: